Chatbots Magazine Become a Writer Intro to Chatbots

Microsoft Bot Framework, messaging endpoint error

Can someone please please help me out. I have been trying for the last 2 weeks trying to deploy a bot to azure and interact with it…The deploying bit i got it covered. The only problem is the setting of the messaging endpoint. I’ve correctly appended /api/messages and made sure the url is https. Just as it’s stated in the docs. So the resulting messaging endpoint is https://gityangu.azurewebsites.net/api/messages.

I however keep getting “NotFound The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.” Error. I cannot seem to find a solution to this

@alyssaong

Can you call your Azure website endpoint from browser or from rest app testing tools like postman?

If your website endpoint is working then bot framework should also be able to connect.

I just checked your Azure endpoint not reachable from browser also. You should check deployment is done correctly

Hey Liam, sorry just saw this! Are you using NodeJS or .NET? Send me a private message if you’re okay with sharing your code. If not then no worries.

Do you have webhook URL? I could publish and use a skype bot using the webhook url (for Api.ai agent).

let me check on that right away

I’m using Node.JS. I don’t mind sharing. Doing so right away

Awesome! Alternatively you can email me at ongalyssa@outlook.com.

But yeah it does look like a deployment issue, so like @rajesh.bindal said check that you’ve deployed/set up continuous deployment properly.

1 Like